Сообщения без ответов | Активные темы Текущее время: 30 ноя 2020, 01:19



Ответить на тему  [ Сообщений: 56 ]  Страница «  1, 2, 3, 4, 5, 6  »
Сборка Elite-Board 2.3.170510 
Автор Сообщение

Зарегистрирован: 16 янв 2016, 22:00
Сообщения: 193

По ходу с ключом так и есть.
Что касается самого обновления до 2.3 то в мануале указаны два способа.
1. Применить само обновление к версии 2.2.170219
2. Применить полный дистрибутив

Что касается первого варианта, то тупо копируете по папкам. Файл config.php остается ваш прежний, он не заменяется. Именно в этом файле прописаны ваши данные для входа вашей же базы данных (которую заранее нужно сохранить). Если при установки требует ввести поля базы данных, то попробуйте ввести данные базы данных вашего файла config.php. Ну а если не получится, то запуска админки, восстановите сохраненную базу данных. По идее так должно быть. По любому сделайте резервную копию базы данных и файлов как на стороне вашего хостинга так и в самой админке. Я сам пока не обновлялся, но в денвере попробуйте мой вариант.

Что касается второго варианта, то при копирование файлов с полного дистрибутива, не переносите файл config.php, так как он стандартный и заменит ваш, который сохранили. Об этом и написано в мануале.


19 май 2017, 13:23
Профиль
Администратор
Аватара пользователя

Зарегистрирован: 20 сен 2010, 21:15
Сообщения: 1628
Аватара пользователя

Если при обновлении 22-23 появляется ошибка "не найдено совместимой БД", значит инсталлятор не увидел в корне сайта файл version.ver с номером текущей сборки. Верните файл version.ver, и всё заработает


19 май 2017, 14:28
Профиль
Администратор
Аватара пользователя

Зарегистрирован: 20 сен 2010, 21:15
Сообщения: 1628
Аватара пользователя

Евгений писал(а):
У меня ЕВ 2.2.150331.Исходя из инструкции нужно обновлять с версии 2.2.170219 Как обновиться до последней версии 2.3.170510, как это сделать,посоветуйте как лучше:
обновиться с версии 2.2.150331 до версии 2.2.170219, а затем перейти на последнюю 2.3.170510 или же лучше установить с полного дистрибутива 2.3 в игнор предидущие сборки? Что я теряю при этом? Спасибо.


Сборка 2.2.150331 довольно старая, её лучше обновить полным дистрибутивом. Скачиваете полный дистрибутив скрипта, распаковываете, загружаете всё кроме config.php и запускаете инсталлятор.

Если вносили изменения в шаблоны или php модули, при обновлении Вы их потеряете. Сделайте резервную копию базы и файлов.


19 май 2017, 14:33
Профиль

Зарегистрирован: 17 май 2015, 15:35
Сообщения: 100

Geo писал(а):
Сборка 2.2.150331 довольно старая, её лучше обновить полным дистрибутивом. Скачиваете полный дистрибутив скрипта, распаковываете, загружаете всё кроме config.php и запускаете инсталлятор.

Вот здесь можно чуточку поподробнее?
1. Скачиваете полный дистрибутив скрипта-скачали!
2. Распаковываете-распаковываем у себя на сайте? Что делать с совпадением имён файлов, папок?
3. загружаете всё кроме config.php- распаковываем всё с заменой более старых файлов, кроме config.php- так что ли?


19 май 2017, 15:13
Профиль
Администратор
Аватара пользователя

Зарегистрирован: 20 сен 2010, 21:15
Сообщения: 1628
Аватара пользователя

Я в таких случаях просто удаляю из архива config.php, загружаю его на сервер и распаковываю с заменой файлов.


19 май 2017, 15:36
Профиль
Администратор
Аватара пользователя

Зарегистрирован: 20 сен 2010, 21:15
Сообщения: 1628
Аватара пользователя

Спасибо большое за отзывы и найденные ошибки!
На следующей неделе будет обновление с исправлениями.


19 май 2017, 15:39
Профиль

Зарегистрирован: 17 май 2015, 15:35
Сообщения: 100

Спасибо.


19 май 2017, 15:44
Профиль

Зарегистрирован: 16 янв 2016, 22:00
Сообщения: 193

Geo писал(а):
Спасибо большое за отзывы и найденные ошибки!
На следующей неделе будет обновление с исправлениями.

И вам спасибо. В обновление войдут исправления в шаблонах?


19 май 2017, 15:51
Профиль

Зарегистрирован: 08 окт 2014, 13:41
Сообщения: 39

Присоединяюсь и вам спасибо за ваш труд Оперативные ответы разработчика внушают оптимизм,доверие и уважение."Будем подождать" :D


19 май 2017, 16:33
Профиль

Зарегистрирован: 17 май 2015, 15:35
Сообщения: 100

Geo писал(а):
Я в таких случаях просто удаляю из архива config.php, загружаю его на сервер и распаковываю с заменой файлов.

Сделал так. Запустил скрипт unzip.php на сайте. Установился скрипт и на сайте вот такая ошибка:
Unknown column 'date_raised' in 'order clause'
Warning: mysql_fetch_assoc() expects parameter 1 to be resource, boolean given in папка сайта/includes/compile/functions.php on line 1
Unknown column 'date_raised' in 'order clause'


19 май 2017, 17:17
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ Сообщений: 56 ] 
Страница «  1, 2, 3, 4, 5, 6  »

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
cron